Firmware V03 for Plato

This is the original firmware for plato,if you don't like firmware V04,you can revert your plato to the original firmware V03.
If the original firmware of your plato is V06, firmwareV03-V05 are not compatible with your plato.
Windows:

New Verification System

Aspire Product verification

Product verification

Aspire Product verification

Are you 18 or older?

AGE VERIFICATION
WARNING : To use the ASPIRE official website you must be aged 18 years or over. Please verify your age before entering the site.